Forum

Problem with pip in...
 
Notifications
Clear all

Problem with pip install Prody and Bioblender requiered python version  

  RSS
GeorgesSR
(@georgessr)
New Member

Hi ! First of all thanks a lot for update this wonderfull software ! You guys are doing amazing work !
I'm encountering an issue while installing as the Manual.pdf instruct to install python 3.5.3 (which I did), then it requires to do install various python package and Prody in particular, but during the installation the minimum version of the python version for Prody seems to be 3.6 not 3.5, and thus the installation fails :

C:\>pip install Prody
Collecting Prody
Downloading https://files.pythonhosted.org/packages/c1/73/e5fc7516f6baefbe68b7c9bc33fdcc818ec1afda1beff2db791ee7d729f1/ProDy-1.10.11-cp35-cp35m-win_amd64.whl (1.7MB)
100% |################################| 1.7MB 941kB/s
Requirement already satisfied: numpy>=1.10 in c:\users\saint\appdata\local\programs\python\python35\lib\site-packages (from Prody)
Collecting biopython (from Prody)
Downloading https://files.pythonhosted.org/packages/3d/2f/d9df24de05d651c5e686ee8fea3afe3985c03ef9ca02f4cc1e7ea10aa31e/biopython-1.77.tar.gz (16.8MB)
100% |################################| 16.8MB 97kB/s
Complete output from command python setup.py egg_info:
Biopython requires Python 3.6 or later. Python 3.5 detected.

----------------------------------------
Command "python setup.py egg_info" failed with error code 1 in C:\Users\Public\Documents\Wondershare\CreatorTemp\pip-build-x8yye226\biopython\

Could someone help me figure out how to properly circumvent this issue ?
Thanks a lot for your time !

Quote
Posted : 05/08/2020 8:43 pm
MonZop
(@monzop)
Active Member

Hi GeorgesSR,

sorry about the delayed response.
We have made some changes, and BioBlender now should also work with Python 3.6.
I will also correct the info on the Manual, possibly next week.

Thanks, Monica

ReplyQuote
Posted : 26/09/2020 3:25 pm

© 2013

About | Links | Contacts | News Archive